Ubuntu on a Dell

I was excited to learn that a major PC manufacturer is finally deciding to offer a Linux distribution on their machines and actually support it, however, there are some very disappointing aspects to the new offerings from Dell. Since I build all of my computers, the only PC’s I would be interested in are the laptops. My Thinkpad T30 is great, but theres a lot of times that I feel the need for a little more power, usually in the realm of a faster video card. So when I started to look at the Ubuntu laptops that Dell is offering, it was a bit of a letdown to see that only one model is available, the Inspiron E 1505N. The worst part about this offering is the lack of choice in terms of the video card that is installed, which is limited to a Intel integrated chip. This is made worse by the fact the the Windows version of the laptop has the option of a 256MB ATI chip. Hopefolly, this is just temporary, because limiting the graphics system in such a way does not place the system on an even footing with other products.

EDIT:  It seems that Dell has changed the system and now allows  the selection of a 256MB GeForce Go 7300 graphics chip.  I’m glad to see that they choose an nVidia chip over an ATI because of the far superior Linux drivers available.  So most of this post is now useless, but I still wish that they offer Ubuntu on more models.  I imagine the main issue with expanding the product line is lack of drivers for the hardware.  This, I hope, will change over time.

Windows is Back

Now that I’ve had some time back from vacation, I decided to do a full investigation into what could be causing my primary Windows machine to fail. After a few hours of experimentation, I’m quite certain that the power supply is what was causing the issues. I currently running it from another 500 watt power supply that was being used in a different machine. The old power supply works, but doesn’t seem to be able to output the same amount of power that it used to, thus causing the problem.

Since I enjoyed using Ubuntu with my flagship hardware, I instituted a dual boot setup on my primary machine, using different hard drives for each OS.

On a different front, I’m contemplating buying a decent video card for the Myth box so that I can get that up and running again with decent hardware. Looking at current prices, one of the fanless GeForce 7600 cards looks appealing. Depending on how the cash situation turns out (aka need a car), that may not happen anytime soon.

Bye Bye Windows!

The motherboard in my one and only Windows machine (aka ompy) has threw in the towel after a few months of agony. The Asus A8N-SLI Premium motherboard has had problems coming online from a cold boot. When I try to turn the machine on, it only stay on for about 5 seconds and then shut off. It will keep doing that , but once in a while it will start. Once the computer boots, everything is dandy, which makes me wonder if theres a flaw in the motherboard itself causing a short early in the boot sequence. Its also possible that the system is drawing too much power too quickly, causing an in-rush current spike, and tripping the built in short circuit protection. I haven’t had the time for do a proper investigation of the problem, but from what I’ve been reading on various forums its a problem with one of the motherboards power regulation transistors.

Since that machine is down and out, I decided to give my main Ubuntud Linux machine (aka gizmonic) a little boost with the EVGA GeForce 7900GT video card that was in my Windows machine. Gizmonic was using a very old PCI video card that was laying around, but after experiencing Beryl with a good video card, I may just have to buy a new card for Linux use only.

Of course the main reasion I was anxious to get a computer up and running was the fact that I just bought Supreme Commander and was really looking forward to playing. Wine was the next best thing, but the install would error after about 95% with the cryptic “Error 25”. I’ve looked around Google, but no one else seems to have tried to get it working under Wine. The only good news is that I sucessfully got Counter Strike Source working.

Since I don’t know when I will have a Windows machine running again, I’m going to take this opportunity and work exclusively with Linux. At the very least, I’m going to turn my main desktop into a dual boot machine so that Linux too can bask in the glory of dual core FX-60 goodness. I plan on putting all my media onto a network storage machine, so that my music, movies, and other fun stuff will be available to both systems, as well as my servers. I want to implement RAID 5 for my network storage, but the good RAID adapters go for $350+. More on my homemade NAS in a later post.

Philips SPC900NC Camera On Linux Is A Go

In researching information about using a webcam as a low cost camera for astrophotography, many people recommended the Philips SPC900NC camera due to its use of a good quality 1.3 megapixel CCD sensor at a decent price. I bought mine from ebay, but its also available on Amazon and Newegg. My first attempt at playing with this camera was on my main desktop running Windows XP x64. This proved useless, however, as the drivers will not work. The Philips software will install fine but it cannot recognize the camera. Windows detects that a USB device is plugged in but can’t do anything with it because of the incompatible driver. I currently do not have a 32 bit version of Windows XP, so the next course of action was obviously Linux.

My laptop currently runs Ubuntu (was running Xubuntu until yesterday, just did a little swap of GUI’s) and was a prime choice. The camera did not work “out-of-the-box” as can be expected, but a little searching netted me a working driver for the camera, known as pwc. The pwc driver works for many Philips cameras, including the SPC900NC that I’m using. Installation is very straightforward for anyone who has compiled programs. Once the driver was installed, Camorama didn’t have a problem detecting the camera and capturing images from it. Next step is to work on capturing video from the camera, which mplayer may do for me.

Since the camera is working, I took a few pictures to test it out. Image quality is pretty good and should work perfectly for my astrophotography plans. Here is a picture of my Tele Vue Pronto refractor that I’ll be using for this project:

tele vue pronto hires